FreePBX Distro (SNG7) on Amazon EC2

NOTE: Special thanks to Andrew Nagy at Sangoma for pointing me to some information that formed the basis of this fix. I had originally created a bug report with a patch that fixed this script, which set the entire thing in motion. Also, this information is being contributed to the community by myself, and the company I own (Voiceopia Communications), in hopes it’ll be of assistance to others. Of course, if you need some turn-key FreePBX stuff, drop us a line!

For quite some time, I have been happily running FreePBX 13 systems (under FreePBX Distro) in the Amazon EC2 cloud without any issues. Once FreePBX 14 went stable, it was the next logical step to set it up to run within EC2 as well, with the idea being to upgrade some of my 13 systems over to it.

Several months of experimentation went by, and I kept running into a common issue: The systems seemed to drop off the network after an hour or so of uptime. Restarting the system via AWS seemed to get things back in order — for another hour or so. Then the process repeats itself. Continue reading “FreePBX Distro (SNG7) on Amazon EC2”

“NO LAN CABLE” error on Grandstream? Try this!

(NOTE: If you’re impatient, there’s a TL;DR at the bottom of the post, but it may not make much sense to you without the rest of the information in the post. Skip there at your own risk…)

A bit of backstory…

For many years, I’ve used the venerable Cisco SPA508G IP phone as my daily driver on both my home and office desks. Throw in a Cisco SPA500DS digital sidecar, and it’s a golden setup. Plenty of keys for speed dialing, other extensions, etc. and all of your sidecar labeling is controlled from the provisioning server — no more fooling with paper inserts!

As such, I’ve always used that setup as my benchmark when evaluating new IP phones for possible use with my customers. The Cisco equipment is solidly built, reliable, sounds great, and is fairly easy to work with.

A year or so back, I started evaluating more “modern” phones with features my customers would like to see, such as color screens, gigabit Ethernet (for passthrough to computers, etc.) I’ve tried phones by Sangoma, Yealink, and probably a few other vendors. The audio quality on the Sangoma, frankly, sucked. I tried to work with them on getting that fixed, to no avail. I can’t remember what happened with the Yealink or others — but in the end, the Cisco setup always ended up on my desk.

Enter Grandstream…

Continue reading ““NO LAN CABLE” error on Grandstream? Try this!”